关于jdk1.5下的代码生成在mac pro系统下配置eclipse编译参数

如果我们的tomcat还是很老的版本,比如tomcat5.5那么它上面运行的java代码只能在jdk1.5的环境下编译,或者兼容jdk1.5的代码,如何做到?

下面我演示如何在eclipse下如何进行设置:


在eclipse的参数设置面板上,选择compiler,然后进行设置:


按照上面的例子,设置为jdk1.5



而对应的要选择jdk1.6因为在mac电脑上,是可以安装jdk1.6的版本的,而且该版本与jdk1.5兼容。
如果这里选错了,比如选择了jdk1.7 那么编译后的类文件,是无法在tomcat5.5版本上运行的,提示不支持的
类版本!

实际上MAC提供了

Download Java for OS X 2017-001

来进行兼容,所以升级系统以后,记得要寻找兼容的补丁包,以支持JDK1.6的版本!






上海数狐信息技术有限公司
您身边的学习服务专家